Alex Donato

Greenhorn
+ Follow
since Aug 28, 2003
Cows and Likes
Cows
Total received
0
In last 30 days
0
Total given
0
Likes
Total received
0
Received in last 30 days
0
Total given
0
Given in last 30 days
0
Forums and Threads
Scavenger Hunt
expand Ranch Hand Scavenger Hunt
expand Greenhorn Scavenger Hunt

Recent posts by Alex Donato

Thanks for the answer, James.
The code of my crawler seems like the one you've posted.
The only difference is about delete before re-create.
I cannot do the same: the search functionality must continues working during indexing so I cannot delete it before new index is complete.
So I create new index using a temp dir. When it finish, the engine stop search , delete old index directory and move temp dir with new indexed page to old dir. Now I try to force a reload of webapp using Tomcat manager ...
Thanks a lot.
If you have any other idea, please let me know!
Have a nice day.
Alex
Thanks for the answer, James.
The code of my crawler seems like the one you've posted.
The only difference is about delete before re-create.
I cannot do the same: the search functionality must continues working during indexing so I cannot delete it before new index is complete.
So I create new index using a temp dir. When it finish, the engine stop search , delete old index directory and move temp dir with new indexed page to old dir. Now I try to force a reload of webapp using Tomcat manager ...
Thanks a lot.
If you have any other idea, please let me know!
Have a nice day.
Alex
16 years ago
Hi all.
I'm having a problem with my search engine which is build on lucene.
It's made of a crawler part and a search part.
When the engine starts, it load the index and the search part is available.
Then I start the crawl service which recreate the index.
At the end, I recreate the IndexReader object.
But it seems it doesn't "see" new indexed pages.
Only if I shutdown and restart the engine it can see new pages ...
Any idea ?
Thanks !!!
Hi all.
I'm having a problem with my search engine which is build on lucene.
It's made of a crawler part and a search part.
When the engine starts, it load the index and the search part is available.
Then I start the crawl service which recreate the index.
At the end, I recreate the IndexReader object.
But it seems it doesn't "see" new indexed pages.
Only if I shutdown and restart the engine it can see new pages ...
Any idea ?
Thanks !!!
16 years ago